Recent Posts

Pages: [1] 2 3 ... 10
1
Maintenance and Servicing / Re: Paddock Stand
« Last post by chassm1 on Yesterday at 04:15 PM »
*Originally Posted by cmb621 [+]
Soooo, I tried to use the abba stand - but they have either sent me the wrong fittings... Or I am a mechanical numpty. I removed the arm pivot cover as instructed and the fittings just would not fit. Anyway I have emailed the company. Lets see....
Hello !
I took delivery my Trident today, rode it home and spent an hour and a couple of phone calls to Abba trying to get it to fit. Removing the plastic S/A covers was a complete pain as others have mentioned. Finally succeeded in operating the stand by doing the exact reverse of the instruction in this thread (which I found while trying to get advice)  I've included photos of what worked for me. You can see which is L/R  by the brake and gear pedals. (female fitting on the LEFT, male fitting on the RIGHT).  I suppose it is entirely possible that Triumph vary/reverse the S/A fittings. Photos attached.




2
Modifications, Accessories, and Appearance / Re: Accessorising completed.
« Last post by Erolek on Yesterday at 10:59 AM »
Yet another little convenience.
Installed colour-coordinated quad lock phone mount, and routed an USB cable in a semi-permanent way (of course - colour-coordinated as well). For obvious reasons I couldn't take a photo with the phone in place.



Usually when the phone is not in use the cable is neatly tucked away with a little rubber waterproof cap.



Greetings
Eryk

3
Maintenance and Servicing / Re: Start up issues?
« Last post by Mister_AtoZ on October 21, 2021, 07.22 PM »
Hi,

I have had the same thing happening on my Trident as well. You described it well :002: . To me, it looks like it is a problem with the gasoline I was using at the time. I had a bigger "batch" of gasoline in jerrycans I got at once. With this gasoline it all started! This gasoline is gone by now and with the new gasoline it starts without a problem.... Curious what was causing the issue, I started experimenting with some different fuel stations. I got gasoline at a more "premium" station first, no issues. Now, I got the gasoline from the station where it all started and the issue is not occurring anymore  :084: . I am still waiting for the bike to rest for a couple of days to see if this makes a difference. All the gasoline I used was 95 octane, so no changes in octane.
I also tried with the bike standing on a paddock stand and on the sidestand (standing in that position for a couple of days), but this doesn't make a difference.
The weather didn't change that much (still bad), so I don't think that has an influence.


Regarding shifting into first, it's sometimes difficult for me as well. What helps for me is releasing the clutch a little bit while pressing down the gearshifter. You can feel it "click" into gear. This is just to get the gears turning a little bit. For the complete information, 3Teeth660 did a great explanation about how it works!  :763: :762:
4
New Member Introductions / Re: Transmission Fault Message on shiny new Trident
« Last post by Akrubek on October 21, 2021, 02.17 PM »
*Originally Posted by korusaki [+]
Shift Force senser short circuit·····

What do you mean by that? Whats wrong exactly? Where from do you know that? Thanks for info:)
5
New Member Introductions / Re: Transmission Fault Message on shiny new Trident
« Last post by Rchrd on October 20, 2021, 06.29 PM »
I get this and I don't have the quick shifter installed
6
Maintenance and Servicing / Re: Rear Brake Issue
« Last post by Cwaig on October 20, 2021, 05.21 PM »
*Originally Posted by 3Teeth660 [+]
Glad to hear it's runnung true now Cwaig. I guess the disk was warped.  Did they give you any other explanation?

Nope - these things happen, I guess - no matter what brand or where it's made, you get occasional QA gremlins. At least it was an quick+easy fix (unlike the "a month and £3000" that Jaguar took to fix my car not long ago  :172:).
7
Maintenance and Servicing / Re: Start up issues?
« Last post by 3Teeth660 on October 20, 2021, 04.27 PM »
Hi mversion,
Yeah, not uncommon for my bike to start second time too.  I don't think it's a problem, but we all expect modern bikes to fire up first time I suppose.

If you ever need to change down from 5th or similar, down to first gear, as it's a sequential 'box, you need the gears rotating slightly to give them a chance to mesh.  It's standard practicice to feather the clutch out slightly between down shifts while you are stationary.  If the engine is not running, rocking the bike back and forth will ease it between gears too, usually neutral to first / second or first to neutral.  Normally though, if you've been stopped in neutral with the engine running, when you pull the clutch in to select first, the gears are still spinning so it clunks into 1st with no problem.  If though you keep the clutch in while in neutral, first gear can be hard to select some of the time as the gears might have come to a standstill.

One eco-option is to flick the kill switch off (and back on) to stop the engine at the lights, having found first gear while still rolling up to the line mind. (Just don't stop the engine while the bike is still moving - the electronics don't like that).  That way you can rest both hands and the bike won't roll.  It's good practice at long-wait level crossings, if you need to chat with a fellow biker and it may be appreciated by car drivers.  You just need to pull in the clutch, hit the starter and off you go.
8
Maintenance and Servicing / Re: Rear Brake Issue
« Last post by 3Teeth660 on October 20, 2021, 03.50 PM »
Glad to hear it's runnung true now Cwaig. I guess the disk was warped.  Did they give you any other explanation?
9
Maintenance and Servicing / Re: Rear Brake Issue
« Last post by Cwaig on October 20, 2021, 10.37 AM »
Finally managed to get the bike out for a lunchtime around-town test run yesterday. The replacement disc has totally sorted the problem :)
10
New Member Introductions / Re: Transmission Fault Message on shiny new Trident
« Last post by korusaki on October 19, 2021, 03.46 PM »
Shift Force senser short circuit·····
Pages: [1] 2 3 ... 10
waisted