Author Factory Heated Grips Install - Display Symbol/Button Works -But Not Warm At All?  (Read 7348 times)

0 Members and 1 Guest are viewing this topic.

  • Offline kitsken   jp

    • 660 Member  ‐    28
    • **
      #90

    Offline kitsken

    • 660 Member
    • **
    • Posts: 28
    • First Triumph Bike
    • Bike: Trident 660
    • City / Town: Okayama
    • Country: jp
    Re: Factory Heated Grips Install - Display Symbol/Button Works -But Not Warm At
    Reply #90 on: January 19, 2023, 12.33 pm
    January 19, 2023, 12.33 pm
    Guess I'm never buying another tech from Triumph again.
    Love their bikes but a simple heated grips can't be fixed.
    Their dealer network is a mess everywhere! I thought it's just Japan but seeing others from different countries amkes me think They just can't handle all the dealer at once.


  • Offline Jaymz   es

    • 660 Member  ‐    30
    • **
      #91

    Offline Jaymz

    • 660 Member
    • **
    • Posts: 30
    • Bike: Trident 660
    • Country: es
    Re: Factory Heated Grips Install - Display Symbol/Button Works -But Not Warm At
    Reply #91 on: January 19, 2023, 05.20 pm
    January 19, 2023, 05.20 pm
    *Originally Posted by kitsken [+]
    Guess I'm never buying another tech from Triumph again.
    Love their bikes but a simple heated grips can't be fixed.
    Their dealer network is a mess everywhere! I thought it's just Japan but seeing others from different countries amkes me think They just can't handle all the dealer at once.

    I knew we had mediocre Triumph service in Spain but I wasn't expecting to be the same in the rest of territories.

    It certainly is a shame.

  • Offline edgeback   us

    • 660 Newbie  ‐    1
    • *
      #92

    Offline edgeback

    • 660 Newbie
    • *
    • Posts: 1
    • Bike: 2023 Trident 660
    • City / Town: Portland, OR
    • Country: us
    Re: Factory Heated Grips Install - Display Symbol/Button Works -But Not Warm At
    Reply #92 on: January 20, 2023, 10.31 pm
    January 20, 2023, 10.31 pm
    Hi everyone, I've been following this thread since I've had the same issue, and am happy to report that I rode home from the Triumph dealership in Beaverton, OR with hot grips on my 2023 Trident for the first time yesterday evening.

    I've been working with Sam, Jon, and Matt at Cascade Moto Portland to try to resolve this issue. I have a 2023 Trident that I took home new in September 2022 with the heated grips, bluetooth, and quickshifter installed.

    The heated grips had never worked. The bike had been in a couple times for break in service and then the "update" that was supposed to fix the issue, but didn't on mine. Last week I called again to try to come to a solution, and they weren't aware at the time of any further issues with the heated grips. They scheduled me for service to try to troubleshoot.
    When I dropped the bike off, Sam had since talked to Triumph who recommended installing a previous software version for the dash. They performed this on Tuesday 1/17/23, and I brought the bike home last night with hot grips for the first time!

    I don't recall or understand exactly what had to be rolled back, but they mentioned that it was specific to the dash software, as if there are other updates that are applied in different pieces that are still up to date. Not too sure, but all the features now work including heated grips, bluetooth, quickshifter, so it seems to have worked. I think this was something that they had to communicate with Triumph about specifically in order to get and apply the correct file, otherwise the computer just wants to update automatically as soon as the bike is plugged in (or something like that, to the best of my understanding of what was told to me).

    Hopefully this can help any others out there with a local Triumph dealership that can't solve the problem. Cascade Moto has not charged me anything for troubleshooting the heated grips. I did ask if Triumph reimburses them for labor hours spent on warranty services, and they told me no. Kinda frustrating to deal with these computer issues on a new bike that is the most technologically advanced bike I've ever had, but it's all working now and luckily the dealership has been quick to get me in and always very friendly.

  • Offline Dash660   us

    • 660 Member  ‐    25
    • **
    • Topic Author
    • #93

    Offline Dash660

    • 660 Member
    • **
    • Topic Author
    • Posts: 25
    • Bike: Trident 660
    • Country: us
    Re: Factory Heated Grips Install - Display Symbol/Button Works -But Not Warm At
    Reply #93 on: January 20, 2023, 11.20 pm
    January 20, 2023, 11.20 pm
    *Originally Posted by edgeback [+]
    Hi everyone, I've been following this thread since I've had the same issue, and am happy to report that I rode home from the Triumph dealership in Beaverton, OR with hot grips on my 2023 Trident for the first time yesterday evening.

    I've been working with Sam, Jon, and Matt at Cascade Moto Portland to try to resolve this issue. I have a 2023 Trident that I took home new in September 2022 with the heated grips, bluetooth, and quickshifter installed.

    The heated grips had never worked. The bike had been in a couple times for break in service and then the "update" that was supposed to fix the issue, but didn't on mine. Last week I called again to try to come to a solution, and they weren't aware at the time of any further issues with the heated grips. They scheduled me for service to try to troubleshoot.
    When I dropped the bike off, Sam had since talked to Triumph who recommended installing a previous software version for the dash. They performed this on Tuesday 1/17/23, and I brought the bike home last night with hot grips for the first time!

    I don't recall or understand exactly what had to be rolled back, but they mentioned that it was specific to the dash software, as if there are other updates that are applied in different pieces that are still up to date. Not too sure, but all the features now work including heated grips, bluetooth, quickshifter, so it seems to have worked. I think this was something that they had to communicate with Triumph about specifically in order to get and apply the correct file, otherwise the computer just wants to update automatically as soon as the bike is plugged in (or something like that, to the best of my understanding of what was told to me).

    Hopefully this can help any others out there with a local Triumph dealership that can't solve the problem. Cascade Moto has not charged me anything for troubleshooting the heated grips. I did ask if Triumph reimburses them for labor hours spent on warranty services, and they told me no. Kinda frustrating to deal with these computer issues on a new bike that is the most technologically advanced bike I've ever had, but it's all working now and luckily the dealership has been quick to get me in and always very friendly.

    That's great news, glad to hear it! I'm still rocking warm grips and my dealer did about the same it sounds like. Told me they went to an earlier version but that was the extent of the details at the time. I'll say that I'm hesitant to add any more components to my Trident at this time, or take it in for service. I feel like we are just a few donuts and foldable chairs away from a support group. I was looking at the 2023 new Street Triple 765 RS coming out this year with great interest, but all the accessories I'd want to purchase from Triumph for it, and this experience, has me holding off diving in. Nothing is perfect but I think we can identify there's some serious communication gaps and QA regarding these updates and the accessories.

  • Offline SlickSix   us

    • 660 Newbie  ‐    2
    • *
      #94

    Offline SlickSix

    • 660 Newbie
    • *
    • Posts: 2
    • Bike: trident 660
    • Country: us
    Re: Factory Heated Grips Install - Display Symbol/Button Works -But Not Warm At
    Reply #94 on: January 27, 2023, 09.44 pm
    January 27, 2023, 09.44 pm
    OK update. They were going to install new handgrips and submit the previous back to Triumph for warranty. Triumph asked them to try a previous version of the software first. I don't know exactly which one, it might have been the original. Anyway, the results are that I now have working heating grips. I feel like maybe the throttle feels a bit more twitchy maybe, but I'm super stoked to have working grips. I'm assuming that some future patch at some point will fix this. But yeah it's 100% a software issue.
    Last Edit: January 27, 2023, 09.45 pm by SlickSix