Author Topic: Trident won't start?!  (Read 388 times)

0 Members and 1 Guest are viewing this topic.

Offline lebuisson

  • 660 Newbie
  • *
  • Topic Author
  • Posts: 4
  • Bike: Trident 660
  • City / Town: Washington DC
  • Country: us
Trident won't start?!
on: April 11, 2021, 10.54 PM
Hey everyone, I just picked up my Trident 660 on Thursday. Road it for 30 miles Thursday afternoon, then another 30 miles Saturday, and then 10 miles this morning. I pulled in to a parking lot for a break. I then tried to start up the bike again, and nothing. No clicking, not a thing. And then the Check Engine light and the Low Oil Pressure lights came on. I let the bike sit, cool down, for a few hours. And still nothing. I bought oil, and then checked the oil levels, those are within the limits now. So... any advice? The dealer doesn't open up until Tuesday. Thanks.

#1

Offline lebuisson

  • 660 Newbie
  • *
  • Topic Author
  • Posts: 4
  • Bike: Trident 660
  • City / Town: Washington DC
  • Country: us
Re: Trident won't start?!
Reply #1 on: April 12, 2021, 06.19 PM
Turns out, to start the bike cold, the bike needs to be in neutral and the clutch pulled in. #ProTip #Learning

#2

Offline kwalmsleyy

  • 660 Member
  • **
  • Posts: 25
  • Country: gb
Re: Trident won't start?!
Reply #2 on: April 12, 2021, 07.30 PM
Glad you’ve sorted it mate, for reference mine will start in gear with the clutch in.

First thing the dealer told me was that you must have the clutch in to start  :008:

#3

Offline Greggor

  • 660 Newbie
  • *
  • Posts: 4
  • Bike: Trident 660. White
  • City / Town: New Plymouth. NZ
  • Country: nz
Re: Trident won't start?!
Reply #3 on: April 19, 2021, 05.03 AM
You can start it in gear - with the clutch in - as long as the side stand is up.  (Which makes sense - if you stall it)  Lots of interlocks.



*Originally Posted by lebuisson [+]
Turns out, to start the bike cold, the bike needs to be in neutral and the clutch pulled in. #ProTip #Learning